Seite 1 von 1

JDK für TREND/Analyst unter MacOS

BeitragVerfasst: 08.09.2014, 07:55
von Katrin_online
Hi Carsten und Co.!
Ich habe in der letzten Woche versucht TREND/Analyst in der aktuellen Version auf meinem Mac zu installieren. Dort ist ein Oracle JDK7 installiert. In der Read-Me Datei gebt Ihr an, dass dies eine kompatible JDK Version ist. Leider sieht es bei mir aber nicht so aus. Beim Start von TREND/Analyst bekomme ich die Fehlermeldung des Systems,dass ich eine Java SE 6 runtime benötige. :(
Was nun?
Gruß,
Katrin

Re: JDK für TREND/Analyst unter MacOS

BeitragVerfasst: 07.10.2014, 07:15
von Carsten Pfeiffer
Hallo Katrin,

der Mac Version liegt ein passendes JDK bei, es wird also gar kein JDK auf dem System selbst erwartet. Die Betriebssystemvoraussetzungen sind:
Mindestens OSX 10.5 (32 Bit)
oder 10.6 (64 Bit)

Welche Version hast Du denn und kannst du evtl. einmal die Fehlermeldung oder einen Screenshot davon posten?

Danke
Carsten

PS: entschuldige bitte die späte Antwort.

Re: JDK für TREND/Analyst unter MacOS

BeitragVerfasst: 12.10.2014, 15:51
von Katrin_online
Hallo Carsten,
schon von Dir zu hören. Auf meinem Mac läuft 10.9.5. Fehlermeldung versuche ich hochzuladen.
Screen Shot 2014-10-12 at 17.48.54.png
Screen Shot 2014-10-12 at 17.48.54.png (42.96 KiB) 35312-mal betrachtet

Bin gespannt, was Du sagst.
Katrin

Re: JDK für TREND/Analyst unter MacOS

BeitragVerfasst: 13.10.2014, 13:32
von Carsten Pfeiffer
Hallo Katrin,

vielen Dank für die Fehlermeldung. Wir konnten das Problem reproduzieren, es gibt auch ellenlange Bugreports und Diskussionen dazu im Eclipse Bugtracker. Die Ursache ist eine aktuelle Version von OSX. In Eclipse gibt es zwar bereits einen Workaround; der funktioniert aber wiederum nur unter bestimmten Umständen. Wir passen uns den Umständen an und stellen so bald wie möglich eine neue Version bereit.

Wenn es eilt, könnte ich auch einen Workaround beschreiben, der allerdings etwas in den Interna rumdoktern würde :-)

Viele Grüße
Carsten Pfeiffer

Re: JDK für TREND/Analyst unter MacOS

BeitragVerfasst: 29.10.2014, 15:22
von Carsten Pfeiffer
Hallo Katrin,

ich habe jetzt mal einen Entwicklerstand von TREND/Analyst 9.0.4 für MacOSX zum Testen hochgeladen. Die Liste der Inkompatibilitäten zwischen den unterschiedlichen OSX Versionen, Java Versionen und Eclipse Versionen ist leider lang. Aber der jetzige Stand funktioniert endlich :-)

Viele Grüße
Carsten Pfeiffer

Re: JDK für TREND/Analyst unter MacOS

BeitragVerfasst: 26.01.2015, 08:28
von Katrin_online
Hi Carsten,
nun endlich komme ich im neuen Job dazu, die Version zu probieren - da ich jetzt kpomplett auf Mac bin :D
Installation erfolgreich! Sollte es danach noch Schwierigkeiten geben, melde ich mich. Tausend Dank!!!!
Katrin

Re: JDK für TREND/Analyst unter MacOS

BeitragVerfasst: 26.01.2015, 16:30
von Carsten Pfeiffer
Hallo Katrin,

das freut mich :-)

Mittlerweile haben wir auch die Version 9.0.4 fertig gestellt und hochgeladen.

Viele Grüße
Carsten

Re: JDK für TREND/Analyst unter MacOS

BeitragVerfasst: 26.03.2017, 17:21
von GeorgTrend
Hallo,

Trend/Analyst startet und dann "nichts"

Ich nutze macOS Sierra 10.12.3 (16D32)

Re: JDK für TREND/Analyst unter MacOS

BeitragVerfasst: 28.03.2017, 11:05
von Carsten Pfeiffer
Hallo Georg,

macOS macht leider immer wieder mal Schwierigkeiten. Wir werden die Kompatibilität für das nächste Release 9.6 sicherstellen.

Wenn man sich ein bisschen auskennt, dann kann man mit dem Finder in den .app Ordner navigieren und die TREND_Analyst.ini Datei mit einem Texteditor öffnen. Dann irgendwo vor der -vmargs Option die Option -nosplash hinzufügen. Eine eventuell vorhandene -showsplash Option mit einem Argument muss dabei gelöscht werden. Dann sollte es eigentlich klappen.

Viele Grüße
Carsten Pfeiffer