Probleme beim installieren des Trend/Analyst als Plugin

Fragen zur Installation. (Offen für alle registrierten Nutzer)

Moderatoren: Carsten Pfeiffer, gebit

Probleme beim installieren des Trend/Analyst als Plugin

Beitragvon Mr_Johnson » 04.08.2009, 09:26

Hallo! :-)
Wollte gerade das Prgramm mal ausprobieren und bin auf folgendes Problem gestossen:

Cannot complete the install because one or more required items could not be found.
Software being installed: TREND/Analyst PVCS Connector 1.0.3 (de.gebit.trend.analyst.pvcs.feature.group 1.0.3)
Missing requirement: TREND/Analyst PVCS Connector 1.0.3 (de.gebit.trend.analyst.pvcs.feature.group 1.0.3) requires 'com.merant.team.pvcs.feature.group 3.0.0' but it could not be found


Wo finde ich dieses Plugin?

Gruß und Danke!
Patrick
Mr_Johnson
 
Beiträge: 4
Registriert: 31.07.2009, 13:59

Beitragvon Carsten Pfeiffer » 04.08.2009, 09:59

Hallo,

die Anbindung an die PVCS-Versionsverwaltung ist optional und kann beim Installieren abgewählt werden (unter Team-Connectors).

Viele Grüße,
Carsten
Carsten Pfeiffer
 
Beiträge: 139
Registriert: 14.03.2007, 14:47

Beitragvon Mr_Johnson » 04.08.2009, 14:02

Danke für die schnelle Antwort... :)

Hab schon das nächste Problem
Cannot complete the install because one or more required items could not be found.
Software being installed: TREND Modeller Plugin 6.5.2.build1115-v20090407093703 (de.gebit.trend.modeller.feature.group 6.5.2.build1115-v20090407093703)
Missing requirement: TREND Modeller Plugin 6.5.2.build1115-v20090407093703 (de.gebit.trend.modeller.feature.group 6.5.2.build1115-v20090407093703) requires 'org.eclipse.platform.feature.group [3.3.0,3.4.0)' but it could not be found


Ich benutze "Eclipse for php - Developers"( 3.5, Galileo).

Gruß
Patrick
Mr_Johnson
 
Beiträge: 4
Registriert: 31.07.2009, 13:59

Beitragvon Carsten Pfeiffer » 04.08.2009, 15:51

Hallo Patrick,

ist das Feature "org.eclipse.platform" installiert? Und wenn ja in welcher Version? Das müsste unter Help -> About Eclipse SDK -> Installation Details -> Features zu finden sein.

Falls das bei der PHP-IDE nicht dabei ist, muss vielleicht noch die Galileo Update-Site eingerichtet werden, damit dieses Feature automatisch mitinstalliert wird.

Viele Grüße,
Carsten
Carsten Pfeiffer
 
Beiträge: 139
Registriert: 14.03.2007, 14:47

Beitragvon Mr_Johnson » 05.08.2009, 07:32

Hallo! :-)

Das Feature ist installiert. Hab mal einen Screenshot angefügt:


Bild


Gruß
Patrick
Mr_Johnson
 
Beiträge: 4
Registriert: 31.07.2009, 13:59

Beitragvon Carsten Pfeiffer » 07.08.2009, 13:58

Hallo,

Eclipse 3.5 wird derzeit noch nicht unterstützt -- voraussichtlich erst mit der nächsten Version 7.0, die für Mitte/Ende September geplant ist.

Viele Grüße,
Carsten Pfeiffer
Carsten Pfeiffer
 
Beiträge: 139
Registriert: 14.03.2007, 14:47

Beitragvon Mr_Johnson » 11.08.2009, 14:16

Vielen Dank für den Hinweis. Ich hab es jetzt mal mit Eclipse 3.4.2 versucht und stosse immer noch auf Probleme:

Cannot complete the request. See the details.
Unsatisfied dependency: [de.gebit.trend.modeller.feature.group 6.5.2.build1115-v20090407093703] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.platform.feature.group/[3.3.0,3.4.0)
Cannot find a solution where both "org.eclipse.platform.feature.group [3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL]" and "org.eclipse.platform.feature.group [3.3.0,3.4.0)" are satisfied.
Cannot find a solution where both "org.eclipse.platform.feature.group [3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL]" and "org.eclipse.platform.feature.group [3.3.0,3.4.0)" are satisfied.
Cannot find a solution where both "org.eclipse.platform.feature.group [3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL]" and "org.eclipse.platform.feature.group [3.3.0,3.4.0)" are satisfied.
Cannot find a solution where both "org.eclipse.platform.feature.group [3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL]" and "org.eclipse.platform.feature.group [3.3.0,3.4.0)" are satisfied.
Cannot find a solution where both "org.eclipse.platform.feature.group [3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL]" and "org.eclipse.platform.feature.group [3.3.0,3.4.0)" are satisfied.
Unsatisfied dependency: [de.gebit.trend.analyst.model.default.feature.group 6.5.2.build1115-v20090407093703] requiredCapability: org.eclipse.equinox.p2.iu/de.gebit.trend.analyst.feature.group/[6.5.2.build1115-v20090407093703,7.0.0)
Unsatisfied dependency: [de.gebit.trend.modeller.feature.group 6.5.2.build1115-v20090407093703] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.platform.feature.group/[3.3.0,3.4.0)
Unsatisfied dependency: [de.gebit.trend.analyst.feature.group 6.5.2.build1115-v20090407093703] requiredCapability: org.eclipse.equinox.p2.iu/de.gebit.trend.modeller.feature.group/[6.5.2.build1115-v20090407093703,6.5.2.build1115-v20090407093703]
Unsatisfied dependency: [de.gebit.trend.metric.feature.group 6.5.2.build1115-v20090407093703] requiredCapability: org.eclipse.equinox.p2.iu/de.gebit.trend.modeller.feature.group/[6.5.2.build1115-v20090407093703,7.0.0)
Unsatisfied dependency: [de.gebit.trend.analyst.model.simple.feature.group 6.5.2.build1115-v20090407093703] requiredCapability: org.eclipse.equinox.p2.iu/de.gebit.trend.analyst.feature.group/[6.5.2.build1115-v20090407093703,7.0.0)
Unsatisfied dependency: [de.gebit.trend.project_control.feature.group 6.5.2.build1115-v20090407093703] requiredCapability: org.eclipse.equinox.p2.iu/de.gebit.trend.modeller.feature.group/[6.5.2.build1115-v20090407093703,7.0.0)
Unsatisfied dependency: [de.gebit.trend.analyst.subclipse.feature.group 1.0.9] requiredCapability: org.eclipse.equinox.p2.iu/de.gebit.trend.analyst.feature.group/6.5.0
Mr_Johnson
 
Beiträge: 4
Registriert: 31.07.2009, 13:59

Beitragvon cgraupner » 03.09.2009, 16:00

Ich habe das selbe Problem.

Und wenn ich mir die Fehlerbeschreibungen so anschaue, fällt auf, dass die Versionsabhängigkeit von der Eclipse-Platform so gesetzt sind, dass eine Version maximal kleiner als 3.4.0 verlangt wird, aber mindestens 3.3.0 (Erkennbar an den Zahlen in den Klammern von "org.eclipse.platform.feature.group [3.3.0,3.4.0)", die runde schließende Klammer "(" bedeutet exklusive, während die eckige "[" inklusive dieser Version bedeutet)

Es wäre schön, wenn die Abhängigkeiten richtig gesetzt werden, damit das auch tatsächlich mal mit Eclipse 3.4.x läuft.

Dass man sich hier auch nur Version 3.5.1 (die RCP-Variante) herunterladen kann und dann das Update auf Version 3.5.2 scheitert, weil diese Abhängigkeit zur PVCS-Komponente existiert oder subclipse und subversive (wer installiert schon beides?!), ist irgendwie auch nicht so recht durchdacht.

Viele Grüße,
Christoph


Mr_Johnson hat geschrieben:Vielen Dank für den Hinweis. Ich hab es jetzt mal mit Eclipse 3.4.2 versucht und stosse immer noch auf Probleme:

Cannot complete the request. See the details.
Unsatisfied dependency: [de.gebit.trend.modeller.feature.group 6.5.2.build1115-v20090407093703] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.platform.feature.group/[3.3.0,3.4.0)
Cannot find a solution where both "org.eclipse.platform.feature.group [3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL]" and "org.eclipse.platform.feature.group [3.3.0,3.4.0)" are satisfied.
Cannot find a solution where both "org.eclipse.platform.feature.group [3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL]" and "org.eclipse.platform.feature.group [3.3.0,3.4.0)" are satisfied.
Cannot find a solution where both "org.eclipse.platform.feature.group [3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL]" and "org.eclipse.platform.feature.group [3.3.0,3.4.0)" are satisfied.
Cannot find a solution where both "org.eclipse.platform.feature.group [3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL]" and "org.eclipse.platform.feature.group [3.3.0,3.4.0)" are satisfied.
Cannot find a solution where both "org.eclipse.platform.feature.group [3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL]" and "org.eclipse.platform.feature.group [3.3.0,3.4.0)" are satisfied.
[...]
cgraupner
 
Beiträge: 2
Registriert: 21.05.2008, 14:41

Beitragvon administrator » 07.09.2009, 10:45

Der Link für die Update-Site war noch der für ältere Versionen, für TREND/Analyst 6.5.x bzw. Eclipse 3.4 muß man diese Update-Site verwenden:

http://www.gebit-community.de/updates/3.4
administrator
Site Admin
 
Beiträge: 72
Registriert: 12.02.2007, 13:05


Zurück zu Installation

Wer ist online?

Mitglieder in diesem Forum: steffen und 1 Gast

cron