TREND/Analyst als Plug-In / Update-Site

Fragen zur Installation. (Offen für alle registrierten Nutzer)

Moderatoren: Carsten Pfeiffer, gebit

TREND/Analyst als Plug-In / Update-Site

Beitragvon administrator » 05.11.2007, 16:21

Auf vielfachen Wunsch beschreiben wir Ihnen hier, wie die Installation von TREND/Analyst als Plug-In zu einer bestehenden Eclipse Installation erfolgen kann. Dieser Schritt ist nur für all jene interessant, die z.B. als Entwickler bereits Eclipse nutzen und aus einer bestehenden Eclipse-Installation den Zugriff auf die TREND/Analyst Features wünschen.

Als Entwickler spart man sich damit das Öffnen von zwei Eclipse-Instanzen: einer für den TREND/Analyst und einer für die Entwicklung. Innerhalb der Entwicklungs-Instanz kann dann ganz einfach durch wechseln auf die "Anforderungen"-Perspektive zum TREND/Analyst gewechselt werden.

Wenn Sie Business Analyst oder Requirements Engineer sind und ausschließlich die Lösung TREND/Analyst nutzen möchten (also keine weiteren Eclipse Plugins etc. haben), empfehlen wir Ihnen wie bisher mit der "Komplettinstallation" zu arbeiten.

* Bequemer Updatemechanismus für klassische TREND/Analyst Nutzer
Aber auch als Nicht-Entwickler können Sie den hier beschriebenen Mechanismus dazu verwenden, neuere TREND/Analyst Versionen zukünftig bequem über einen Updatemechanismus zu erhalten. Hierzu folgen Sie einfach unten stehenden Installationshinweisen und führen diese auf Basis Ihrer zuvor erfolgten TREND/Analyst Komplettinstallation durch.

Achtung! Sie müssen für den Updatemechanismus mindestens die TREND/Analyst Version 6.1.2 nutzen. Die aktuelle Version 6.2.1 können Sie sich hier im Forum herunterladen.


WICHTIG !!!
Zur Installation von TREND/Analyst als Plug-In raten wir ausschließlich erfahrenen Entwicklern, die im Umgang mit Plug-Ins vertraut sind. Wir können leider keine Gewähr dafür übernehmen, dass es nicht zu Konflikten zwischen TREND/Analyst und ihren eventuell bereits installierten PlugIns kommen könnte.
Zur Sicherheit erstellen Sie bitte zuvor ein Backup Ihre Eclipse Installation.



How-To ? Die Installation als Plug-In
Der Schlüssel zur Installation (und Aktualisierung) liegt in der Nutzung des Standard Eclipse Update-Site Mechanismus.

Für Version 6.5.x / Eclipse 3.4:
Die URL der Update-Site von TREND/Analyst ist: http://www.gebit-community.de/updates/3.4

Für ältere Versionen / Eclipse 3.3:
Die URL der Update-Site von TREND/Analyst ist: http://www.gebit-community.de/updates/3.3


Voraussetzung ist:
Eclipse 3.4 (SDK oder Platform + JDT + PDT) mit mindestens Java 1.5/5.0.

Zu installieren geht es mit über "Help" > "Software Updates" > "Suchen und Installieren/Find and Install" > "Neu zu installierende Features suchen/Search for new features to install". Hier legt man dann eine "neue ferne Site/New Remote Site..." an:

Bild

...man verwendet seine Login-Daten der gebit-community.de:


Bild
...wählt dann alles aus:


Bild

...bestätigt noch die Lizenzen, wartet (download) und startet dann Eclipse neu. Das ganze geht mit Windows & Linux sowie Eclipse 3.4 (SDK oder Platform + JDT + PDT) mit mindestens Java 1.5/5.0.

Folgende Unterschiede zum Komplettpaket bestehen:

* Eclipse wird dadurch nicht deutsch (-> ggf. Sprach-Misch-Masch)
* Kein TREND/Analyst Splash Screen
* Es wird nichts von Eclipse ausgeblendet (Run/Debug/Java/...)


Wir wünschen Ihnen viel Erfolg beim Einsatz von TREND/Analyst Community Edition
Ihre GEBIT Solutions
Zuletzt geändert von administrator am 07.09.2009, 10:48, insgesamt 5-mal geändert.
administrator
Site Admin
 
Beiträge: 72
Registriert: 12.02.2007, 13:05

Beitragvon karakas » 03.05.2008, 09:45

Ist Eclipse 3.3 zwingend erforderlich? Geht 3.2 nicht auch?
karakas
 
Beiträge: 2
Registriert: 02.05.2008, 17:37

Beitragvon karakas » 03.05.2008, 10:07

Ich wollte nicht warten und beschloß selber herauszufinden, was passiert wenn man doch "nur" die Version 3.2 von Eclipse benutzt. Schon beim Anklicken des zu installierenden Features bekam ich die Meldung:

Code: Alles auswählen
EMFDevice Feature (1.1.0) operating system does not match current environment.


Nun gut, ich deaktivierte das Feature "EMFDevice Feature". Prompt schlug die "Eclipse Plugin Hell" zurück:

Code: Alles auswählen
WST Web Services UI (1.5.3.v200701251933-hai7Hmzwm3L_T5K) requires feature "org.eclipse.gef (3.2.0)", or equivalent.


Aber ich habe schon "org.eclipse.gef_3.2.2.v20070208", also eigentlich "besser" als das geforderte "GEF 3.2.0". Funktioniert denn TREND/Analyst nur mit GEF 3.2.0, aber nicht mit GEF 3.2.2 etwa? Schwer zu glauben, ich vermute einen Konfigurations-Bug...

Wie auch immer, gab es etliche Unterfeatures die deaktiviert waren, wahrscheinlich aufgrund dieser zwei Fehler (oder sogar auch wegen anderer Gründe) - und es blieb mir nicht anderes übrig, als auf "Cancel" zu klicken...
karakas
 
Beiträge: 2
Registriert: 02.05.2008, 17:37

Beitragvon Carsten Pfeiffer » 15.05.2008, 10:08

Hallo,

das EMF-Feature ist optional und kann in der Tat weggeklickt werden (dann kann man lediglich keine Windows WMF-Dateien erzeugen).

Code: Alles auswählen
WST Web Services UI (1.5.3.v200701251933-hai7Hmzwm3L_T5K) requires feature "org.eclipse.gef (3.2.0)", or equivalent.


Das WST-Feature gehört nicht zum Analyst, das muss schon vorher in der lokalen Eclipse-Installation vorhanden gewesen sein. In der Tat verwendet der Analyst genau GEF Version 3.2.2, die vorhandene Version sollte daher ausreichen, sodass die Version in der Analyst Update Site gar nicht installiert werden würde.

Ich vermute daher, dass das installierte WST schon jetzt nicht korrekt funktioniert bzw. keine korrekten Abhängigkeiten zu GEF hat und erst die Verwendung vom Update-Manager das Problem zu Tage gebracht hat.

Wenn WST gar nicht benutzt wird, würde ich es in dem Fall einfach deinstallieren.

Trotzdem verstehe ich die Fehlermeldung nicht, dann gef 3.2.2 ist äquivalent zu 3.2.0. Es sieht so aus, als würde entweder GEF komplett deinstalliert oder eine nicht-äquivalente Version installiert werden sollen (z.B. 3.3.x).

Viele Grüße,
Carsten
Carsten Pfeiffer
 
Beiträge: 139
Registriert: 14.03.2007, 14:47

Ganymed?

Beitragvon ramjam » 22.07.2008, 12:22

Hat sich irgendjemand mal an einer Integration in Ganymed (Eclipse 3.4) versucht?
Ich bekomme dauernd eine nicht erfüllte Abhängigkeit einer bestimmten Equinox-Version, obwohl diese eigentlich installiert sein sollte.

Da ich nicht zwei Eclipse für ein Projekt führen möchte, dennoch gerne mit 3.4 arbeiten würde, wäre ich für Tipps dankbar!

Viele Grüße,
Roland
ramjam
 
Beiträge: 1
Registriert: 21.07.2008, 15:11

Beitragvon Carsten Pfeiffer » 22.07.2008, 14:52

Da es derzeit noch einige Probleme mit Eclipse 3.4 gibt und der Status der Übersetzungen nicht klar ist, stellen wir den TREND Analyst für Eclipse 3.4 noch nicht zur Verfügung.

Spätestens für Eclipse 3.4.1 wird es den Analyst geben.
Carsten Pfeiffer
 
Beiträge: 139
Registriert: 14.03.2007, 14:47

Beitragvon cgraupner » 08.12.2008, 14:01

Hallo allerseits,

Eclipse 3.4.1 ist erschienen. Wird es bald eine Trend/Analyst Version für Ganymed geben?

Viele Grüße,
Christoph
cgraupner
 
Beiträge: 2
Registriert: 21.05.2008, 14:41

fehlende Übersetzungen

Beitragvon Carsten Pfeiffer » 09.12.2008, 11:10

Hallo,

der hauptsächliche Showstopper sind leider immer noch fehlende Übersetzungen, bzw. eine Möglichkeit, Übersetzungen zu installieren, ohne sich die Eclipse-Installation zu ruinieren.

Aber auch an der Front wird gearbeitet, so dass der Analyst 6.5, der Anfang nächsten Jahres erscheinen wird, auch für Eclipse 3.4 verfügbar sein wird.

Viele Grüße,
Carsten Pfeiffer
Carsten Pfeiffer
 
Beiträge: 139
Registriert: 14.03.2007, 14:47

Beitragvon Andre Krick » 26.01.2009, 13:13

Hallo,

gibt es schon ein Release-Datum für Version 6.5 bzw. ein Update für Eclipse 3.4/3.4.1?


VG
Andre Krick
 
Beiträge: 1
Registriert: 26.01.2009, 12:14

Fehler bei Installation auf Eclipse 3.4.2 per Update-Site

Beitragvon Holger.Buchner » 06.03.2009, 10:23

Hallo Zusammen,
habe heute direkt versucht, den neuen Trend/Analyst auf Eclipse 3.4.2 per Update Site zu installieren und bekomme eine Fehlermeldung bezüglich der Editor.UI
Code: Alles auswählen
Cannot find a solution satisfying the following requirements org.eclipse.ui.editors [3.4.0.v20080603-2000]

Läuft der neue Trend/Analyst nur auf Ganymede 3.4.0 ?
Holger.Buchner
 
Beiträge: 3
Registriert: 01.08.2008, 12:03

Nächste

Zurück zu Installation

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast